Configurazione del firmware Mikrotik

Colleghiamo il Mikrotik al nostro modem/router tramite la porta "ether1" ed effettuiamo un reset del dispositivo alle impostazioni di fabbrica. Utilizziamo WinBox per collegarci al Mikrotik ed apriamo il terminale cliccando su "New Terminal" nel menù di sinistra.
Per resettare il dispositivo digitiamo il comando:

/system reset-configuration

Configurazione IP

Dopo la richiesta di conferma il dispositivo si riavvierà automaticamente.
Attendiamo un paio di minuti ed effettuiamo nuovamente il login con WinBox. Apriamo nuovamente il terminale ed impartiamo i seguenti comandi:

/ip address remove [find]
/ip address add address=192.168.1.100/24 interface=ether1
/ip route add gateway 192.168.1.1
/ip dns set server=8.8.8.8

I precedenti comandi sono validi se il vostro modem è impostato sull'indirizzo 192.168.1.1. Nel caso in cui sia impostato su un indirizzo diverso, ad esempio 192.168.0.1, i comandi saranno i seguenti:

/ip address remove [find]
/ip address add address=192.168.0.100/24 interface=ether1
/ip route add gateway 192.168.0.1
/ip dns set server=8.8.8.8

Apertura delle porte sul modem/router

Per poter utilizzare alcune funzioni di My Wi-Fi Service è necessario che il router wireless sia raggiungibile dall'esterno (da internet) sulle porte 22 TCP e 3779 UDP.
La porta 22 TCP viene utilizzata per accedere al router tramite il protocollo SSH che ci offre la possibilità di utilizzare la funzione di riavvio del router (reboot) ed invio dello script di configurazione, mentre la porta 3779 UDP consente di inviare al router il comando per effettuare il logout forzato di un utente.

All'interno del vostro modem/router dovrete quindi "girare" le porte 22 TCP e 3779 UDP verso l'indirizzo della porta WAN del router wireless. In base alla procedura di configurazione eseguita al passo precedente, tale indirizzo è impostato sul valore 192.168.1.100 se il vostro modem è sull'indirizzo 192.168.1.1 oppure su 192.168.0.100 se l'indirizzo del modem è 192.168.0.1 etc.

Affinché il router wireless della location sia raggiungibile dall'esterno è anche indispensabile che all'interno della configurazione della location sia indicato l'indirizzo IP pubblico del modem.
Se la vostra connessione ADSL non dispone di un IP statico potrete anche utilizzare un nome host di un servizio di dns dinamico come no-ip.org o dyndns.org.

Esecuzione dello script di configurazione

Effettuiamo ora il login all'applicativo My Wi-Fi Service collegandoci all'indirizzo https://app.mywifiservice.com. Dalla schermata principale selezioniamo la pagina Location e modifichiamo la location predefinita "Default location" impostando "Mikrotik" nella casella "Tipo di Dispositivo". Impostiamo "admin" come nome utente e lasciamo vuoto il campo password. Alla voce "interfaccia hotspot" dovremo selezionare l'interfaccia del Mikrotik che diffonde il segnale WI-FI.
Confermiamo le modifiche e clicchiamo sulla voce "Invia lo script di configurazione" del menù Operazioni della location. A questo punto l'hotspot sarà pronto ad essere utilizzato.

Softvision s.r.l. - Via Cesare Battisti, 101 - 67051 Avezzano (AQ) - Italy - P.IVA 01564100665 - Privacy Policy

View this web site in others language : Ita | Eng | Fre | Spa | Por | Ger
Wi-Fi and business activities

MyWiFi