MyWiFi

Configurazione del firmware Mikrotik

Colleghiamo il Mikrotik al nostro modem/router tramite la porta "ether1" ed effettuiamo un reset del dispositivo alle impostazioni di fabbrica. Utilizziamo WinBox per collegarci al Mikrotik ed apriamo il terminale cliccando su "New Terminal" nel menù di sinistra.
Per resettare il dispositivo digitiamo il comando:


/system reset-configuration no-default=yes

Configurazione IP

Dopo la richiesta di conferma il dispositivo si riavvierà automaticamente.
Attendiamo un paio di minuti ed effettuiamo nuovamente il login con WinBox. Apriamo nuovamente il terminale ed impartiamo i seguenti comandi:


/ip dhcp-client add disabled=no interface=ether1
/ip dns set server=8.8.8.8


Esecuzione dello script di configurazione

Effettuiamo ora il login all'applicativo My Wi-Fi Service collegandoci all'indirizzo https://app.mywifiservice.com. Dalla schermata principale selezioniamo la pagina Location e modifichiamo la location predefinita "Default location" impostando "Mikrotik" nella casella "Tipo di Dispositivo". Impostiamo "admin" come nome utente e lasciamo vuoto il campo password. Alla voce "interfaccia hotspot" dovremo selezionare l'interfaccia del Mikrotik che diffonde il segnale WI-FI.
Confermiamo le modifiche, poi dall'elenco delle location clicchiamo sul bottone "Config. disp." oppure, se la location è già stata configurata, sulla voce "Configurazione del dispositivo" del relativo menù e copiamo il testo visualizzato. Ora apriamo Winbox (con un account "amministratore"), clicchiamo su "New Terminal", ed incolliamo il testo dello script precedentemente copiato. A questo punto l'hotspot sarà pronto ad essere utilizzato.